What’s Vulnerable › Vulnerabilities
CVE-2026-58588: Drupal Canvas - Moderately critical - Improper validation - SA-CONTRIB-2026-066
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-10 · updated 2026-10-25
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal Canvas allows Cross-Site Scripting (XSS). This issue affects Drupal Canvas versions: from 0.0.0 to 1.4.2, from 1.5.0 to 1.5.2, from 1.6.0 to 1.6.1, from 1.7.0 to 1.7.1.
Affected products
- Drupal Canvas: before 1.4.2; from 1.5.0 before 1.5.2; from 1.6.0 before 1.6.1; from 1.7.0 before 1.7.1 — fixed in 1.4.2, 1.5.2, 1.6.1, 1.7.1
How to fix
Upgrade to a fixed version: Drupal Canvas 1.4.2, 1.5.2, 1.6.1, 1.7.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-58588 or the next vulnerability affects your stack