What’s Vulnerable › Vulnerabilities
CVE-2026-58652: luci-app-travelmate - Arbitrary Command Execution via UCI Script Parameter
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-02 · updated 2026-10-29
- Weakness: CWE-78
Description
luci-app-travelmate (and the travelmate package) contain a privilege-escalation flaw: a LuCI/rpcd session holding the luci-app-travelmate write ACL is granted config-wide UCI write access to the travelmate configuration. While the LuCI UI restricts the auto-login script picker to /etc/travelmate/*.login, this is only a frontend restriction. The backend travelmate service (running as root) reads the raw UCI 'script' and 'script_args' values and executes the configured path when the captive-portal auto-login branch (f_check() in travelmate-functions.sh) is reached. An attacker with delegated write permissions can set script to /bin/sh and script_args to attacker-controlled arguments, resulting in arbitrary command execution as root. Confirmed in luci-app-travelmate/travelmate 2.4.5-r3; travelmate 2.4.6-1 is also affected. Fixed in travelmate 2.4.6-2, which enforces the /etc/travelmate/*.login allowlist in the backend.
Affected products
- openwrt luci-app-travelmate: 2.4.5-r3
- openwrt travelmate: before 2.4.6-2 — fixed in 2.4.6-2
How to fix
Upgrade to a fixed version: openwrt travelmate 2.4.6-2. Check the vendor advisory for mitigations.
References
- https://github.com/openwrt/luci/security/advisories/GHSA-p35r-3323-6g7g
- https://github.com/openwrt/packages/commit/0627b412ee3a760cc4bca9fc8a5b73de8f33ac10
- https://github.com/openwrt/packages/commit/71d92bcc9edbc8f95858ce82a8ff5d52500005a2
- https://github.com/openwrt/packages/commit/d6e457a1a70a9010195edeafdc0b8eb6e3b0f7f1
- https://www.vulncheck.com/advisories/luci-app-travelmate-arbitrary-command-execution-via-uci-script-parameter
- https://github.com/openwrt/luci/security/advisories/GHSA-p35r-3323-6g7g
Get alerted when CVE-2026-58652 or the next vulnerability affects your stack