What’s Vulnerable › Vulnerabilities
CVE-2026-59084: Apache Tomcat: EncryptInterceptor requirements not clearly documented
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-10-24
- Weakness: CWE-1059
Description
Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue.
Affected products
- Apache Tomcat: from 7.0.100 through 7.0.109; from 8.5.38 through 8.5.100; from 9.0.13 through 9.0.119; from 10.1.0 through 10.1.56; from 11.0.0 through 11.0.23
References
- https://lists.apache.org/thread/7w9746ootcxo0gvx26xjpw80l31f1qw7
- http://www.openwall.com/lists/oss-security/2026/07/14/8
Get alerted when CVE-2026-59084 or the next vulnerability affects your stack