What’s Vulnerable › Vulnerabilities
CVE-2026-59085: Apache CloudStack: Server-Side Request Forgery (SSRF) vulnerability in webhook module
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-21 · updated 2026-10-16
- Weakness: CWE-918
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache CloudStack's webhook module, exploitable via webhook delivery requests. This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.
Affected products
- Apache Software Foundation Apache CloudStack: from 4.20.0.0 before 4.20.3.1; from 4.21.0.0 before 4.22.1.1 — fixed in 4.20.3.1, 4.22.1.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CloudStack 4.20.3.1, 4.22.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-59085 or the next vulnerability affects your stack