What’s Vulnerable › Vulnerabilities
CVE-2026-59095: LobeChat < 2.2.10-canary.18 - SSRF via importFromUrl and fetchImageFromUrl
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-02 · updated 2026-09-30
- Weakness: CWE-918
Description
LobeChat before 2.2.10-canary.18 contains a server-side request forgery vulnerability that allows authenticated attackers to direct internal HTTP requests to arbitrary URLs by supplying user-controlled input to the skill import service (importFromUrl) and topic cover update (fetchImageFromUrl) endpoints, which use the global fetch without the project's ssrf-safe-fetch wrapper. Attackers can target internal addresses such as cloud instance metadata endpoints through these unprotected code paths to disclose internal service responses and cloud credentials.
Affected products
- lobehub: before 2.2.10 — fixed in 2.2.10
How to fix
Upgrade to a fixed version: lobehub 2.2.10. Check the vendor advisory for mitigations.
References
- https://github.com/lobehub/lobehub/issues/16536
- https://github.com/lobehub/lobehub/pull/16601
- https://www.vulncheck.com/advisories/lobechat-canary-18-ssrf-via-importfromurl-and-fetchimagefromurl
Get alerted when CVE-2026-59095 or the next vulnerability affects your stack