What’s Vulnerable › Vulnerabilities
CVE-2026-59153: Anki's local HTTP server does not sufficiently validate requests
- Severity: low (CVSS 2.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-07 · updated 2026-10-25
- Weakness: CWE-346
Description
Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, Anki launches a local HTTP server to serve media files and web pages for parts of its interface, but requests from other origins were not sufficiently blocked. A malicious website could potentially trigger side-effecting requests to the local server, with severity varying by browser depending on Private Network Access protections. This issue is fixed in version 25.09.3.
Affected products
- Ankitects Anki: before 25.09.3
References
- https://github.com/ankitects/anki/commit/858e5689d0e4fd24f74856c7e8f245412694a219
- https://github.com/ankitects/anki/releases/tag/25.09.3
- https://github.com/ankitects/anki/security/advisories/GHSA-869j-r97x-hx2g
- https://x.com/taviso/status/2051310678800253318
Get alerted when CVE-2026-59153 or the next vulnerability affects your stack