What’s Vulnerable › Vulnerabilities
CVE-2026-59195: pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-06 · updated 2026-07-07
- Weakness: CWE-22
Description
pnpm is a package manager. Prior to 10.34.4 and 11.8.0, pnpm accepts package names from the env lockfile configDependencies section and uses those names directly when creating config dependency symlinks under node_modules/.pnpm-config. A malicious repository can commit a crafted pnpm-lock.yaml whose env-lockfile document contains a traversal-shaped config dependency name. During pnpm install, pnpm installs the config dependency and creates a symlink at a path derived from that name. This vulnerability is fixed in 10.34.4 and 11.8.0.
Affected products
- pnpm: before 10.34.4; from 11.0.0 before 11.8.0 — fixed in 10.34.4, 11.8.0
How to fix
Upgrade to a fixed version: pnpm 10.34.4, 11.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-qrv3-253h-g69c
- https://github.com/pnpm/pnpm/security/advisories/GHSA-qrv3-253h-g69c
Get alerted when CVE-2026-59195 or the next vulnerability affects your stack