What’s Vulnerable › Vulnerabilities
CVE-2026-59229: Apache IoTDB: Legacy Pipe Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-30
- Weakness: CWE-798
Description
The Legacy Pipe receiver protocol (handshake / sendPipeData) uses a hardcoded SUPER_USER (root) identity when executing data loading and deletion operations. A user with only SYSTEM-level privileges (such as USE_PIPE or MAINTAIN) who does NOT have WRITE_DATA or DELETE_DATA permissions on target databases can send specially crafted PipeData messages through the Legacy Pipe API, resulting in data loading/deletion operations executed as root — effectively bypassing IoTDB's permission model entirely. This issue affects Apache IoTDB: from 2.0.0 before 2.0.11. Users are recommended to upgrade to version 2.0.11, which fixes the issue.
Affected products
- Apache Software Foundation Apache IoTDB: from 2.0.0 before 2.0.11 — fixed in 2.0.11
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache IoTDB 2.0.11. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/yzx26fb9v1vwk1zqs700cf1mrctjrb3d
- http://www.openwall.com/lists/oss-security/2026/10/21/21
Get alerted when CVE-2026-59229 or the next vulnerability affects your stack