What’s Vulnerable › Vulnerabilities

CVE-2026-59259: n8n - Permission Bypass via Expression Parser Mismatch in External Secrets

Description

n8n before versions 1.123.61, 2.27.4, and 2.28.1 contains a permission bypass vulnerability in external secrets handling caused by a mismatch between the static validation check and the runtime expression engine. An authenticated user with credential create or update permissions but without the externalSecret:list scope can embed external secret references into credentials in forms the static validation does not detect; these references resolve at workflow execution time, exposing secret values the user is not authorized to access. This issue only affects instances where an external secrets provider is configured and Advanced Permissions are in use.

Affected products

How to fix

Upgrade to a fixed version: n8n-io n8n 1.123.61, 2.27.4; n8n-io n8n 1.123.61. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-59259 or the next vulnerability affects your stack