What’s Vulnerable › Vulnerabilities
CVE-2026-59260: OpenWrt luci-app-samba4 read ACL remote code execution via smbd
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-12 · updated 2026-10-24
- Weakness: CWE-269
Description
OpenWrt luci-app-samba4 read ACL grants file.exec permission on /usr/sbin/smbd, allowing authenticated delegated users to execute the Samba daemon with caller-controlled command-line arguments. Attackers can pass arbitrary Samba global options such as message command to a root smbd process, triggering command execution when SMB protocol messages are processed.
Affected products
- openwrt luci: before 24.10.8; from 25.12.0 before 25.12.5 — fixed in 24.10.8, 25.12.5
How to fix
Upgrade to a fixed version: openwrt luci 24.10.8, 25.12.5. Check the vendor advisory for mitigations.
References
- https://github.com/openwrt/luci/security/advisories/GHSA-vx64-mmp7-h36c
- https://www.vulncheck.com/advisories/openwrt-luci-app-samba4-read-acl-remote-code-execution-via-smbd
- https://github.com/openwrt/luci/security/advisories/GHSA-vx64-mmp7-h36c
Get alerted when CVE-2026-59260 or the next vulnerability affects your stack