What’s Vulnerable › Vulnerabilities
CVE-2026-59261: OpenClaw < 2026.5.28 - Credential Override via Workspace Dotenv Files
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-10-25
- Weakness: CWE-184
Description
OpenClaw before 2026.5.28 contains a credential exposure vulnerability where workspace dotenv files can override provider credentials. Attackers with lower-trust access to configured input paths can expose sensitive data and credentials that should remain within trusted boundaries.
Affected products
- OpenClaw: before 2026.5.28 — fixed in 2026.5.28
How to fix
Upgrade to a fixed version: OpenClaw 2026.5.28. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-4pqj-3c56-5fqq
- https://www.vulncheck.com/advisories/openclaw-credential-override-via-workspace-dotenv-files
Get alerted when CVE-2026-59261 or the next vulnerability affects your stack