What’s Vulnerable › Vulnerabilities

CVE-2026-59275: Remote JVM termination: nested-array Java deserialization bypasses allowlist, triggers StackOverflowError, default JavaLangErrorHandler calls System.exit(99)

Description

A single hostile AMQP message can terminate the entire consumer JVM (System.exit(99)), not just the listener thread — full availability loss for every workload co-located in that process. Spring AMQP 4.1.0 Spring AMQP 4.0.0 - 4.0.4 Spring AMQP 3.2.0 - 3.2.12 Spring AMQP 2.4.18 and earlier

Affected products

How to fix

Upgrade to a fixed version: Spring AMQP 2.4.19, 3.2.13, 4.0.4.1, 4.1.0.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-59275 or the next vulnerability affects your stack