What’s Vulnerable › Vulnerabilities

CVE-2026-59278: In Spring for Apache Kafka, SSRF via DNS resolution triggered by untrusted java.net types in header mapper default trusted packages

Description

JsonKafkaHeaderMapper and DefaultKafkaHeaderMapper include java.net in their default trusted packages list. When these mappers are used — which is the default configuration for all @KafkaListener consumers — an external Kafka producer can inject a java.net.InetAddress type via the spring_json_header_types message header. Spring for Apache Kafka 4.1.0 Spring for Apache Kafka 4.0.0 - 4.0.6 Spring for Apache Kafka 3.0.0 - 3.3.16 Spring for Apache Kafka 2.9.0 - 2.9.14 Spring for Apache Kafka 2.8.12 and earlier

Affected products

How to fix

Upgrade to a fixed version: Spring for Apache Kafka 2.8.13, 2.9.15, 3.3.17, 4.0.6.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-59278 or the next vulnerability affects your stack