What’s Vulnerable › Vulnerabilities
CVE-2026-59281: Spring Framework Cross-site Scripting via EscapedErrors
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-09-02
- Weakness: CWE-79
Description
Spring MVC and WebFlux applications that obtain a data-binding Errors instance with HTML escaping enabled and then render field errors using the no-argument Errors.getFieldErrors() or Errors.getFieldError() accessors are vulnerable to arbitrary HTML/JavaScript code injection, potentially resulting in a reflected cross-site scripting (XSS) vulnerability. Spring Framework 7.0.0 - 7.0.8 Spring Framework 6.2.0 - 6.2.19 Spring Framework 6.1.0 - 6.1.28 Spring Framework 6.0.0 - 6.0.30 Spring Framework 5.3.0 - 5.3.49 Spring Framework 5.2.25.RELEASE and earlier
Affected products
- Spring Framework: before 5.2.26; from 5.3.0 before 5.3.50; from 6.0.0 before 6.0.31; from 6.1.0 before 6.1.29; from 6.2.0 before 6.2.20; from 7.0.0 before 7.0.8.1 — fixed in 5.2.26, 5.3.50, 6.0.31, 6.1.29, 6.2.20, 7.0.8.1
- Spring Framework: from 7.0.0 through 7.0.8; from 6.2.0 through 6.2.19; from 6.1.0 through 6.1.28; from 6.0.0 through 6.0.30; from 5.3.0 through 5.3.49; through 5.2.25.RELEASE
How to fix
Upgrade to a fixed version: Spring Framework 5.2.26, 5.3.50, 6.0.31, 6.1.29. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-59281 or the next vulnerability affects your stack