What’s Vulnerable › Vulnerabilities
CVE-2026-59285: Spring for GraphQL Unsafe Deserialization in pagination support
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-09-02
- Weakness: CWE-502
Description
Spring for GraphQL applications are vulnerable to Unsafe Deserialization when processing paginated GraphQL queries. Spring for GraphQL 2.0.0 - 2.0.4
Affected products
- Spring for GraphQL: from 2.0.0 before 2.0.4.1 — fixed in 2.0.4.1
- Spring for GraphQL: from 2.0.0 through 2.0.4
How to fix
Upgrade to a fixed version: Spring for GraphQL 2.0.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-59285 or the next vulnerability affects your stack