What’s Vulnerable › Vulnerabilities
CVE-2026-59287: Spring for GraphQL WebSocket Client Denial of Service
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-09-02
- Weakness: CWE-770
Description
Spring for GraphQL is vulnerable to Denial of Service attacks when using the WebSocket client with keepAlive enabled. Spring for GraphQL 2.0.0 - 2.0.4 Spring for GraphQL 1.4.0 - 1.4.6 Spring for GraphQL 1.3.0 - 1.3.9
Affected products
- Spring for GraphQL: from 1.3.0 before 1.3.10; from 1.4.0 before 1.4.7; from 2.0.0 before 2.0.4.1 — fixed in 1.3.10, 1.4.7, 2.0.4.1
- Spring for GraphQL: from 2.0.0 through 2.0.4; from 1.4.0 through 1.4.6; from 1.3.0 through 1.3.9
How to fix
Upgrade to a fixed version: Spring for GraphQL 1.3.10, 1.4.7, 2.0.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-59287 or the next vulnerability affects your stack