What’s Vulnerable › Vulnerabilities
CVE-2026-59288: Spring for GraphQL Information Exposure in GraphiQL support
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-09-01
- Weakness: CWE-200
Description
The GraphiQL page bundled with Spring for GraphQL sends requests to the GraphQL endpoints of the application. An attacker can share a malicious URL so that the victim's browser might leak confidential information to the attacker's website. Spring for GraphQL 2.0.0 - 2.0.4 Spring for GraphQL 1.4.0 - 1.4.6 Spring for GraphQL 1.1.0 - 1.3.9 Spring for GraphQL 1.0.0 - 1.0.7
Affected products
- Spring for GraphQL: from 1.0.0 before 1.0.8; from 1.1.0 before 1.3.10; from 1.4.0 before 1.4.7; from 2.0.0 before 2.0.4.1 — fixed in 1.0.8, 1.3.10, 1.4.7, 2.0.4.1
- Spring for GraphQL: from 2.0.0 through 2.0.4; from 1.4.0 through 1.4.6; from 1.1.0 through 1.3.9; from 1.0.0 through 1.0.7
How to fix
Upgrade to a fixed version: Spring for GraphQL 1.0.8, 1.3.10, 1.4.7, 2.0.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-59288 or the next vulnerability affects your stack