What’s Vulnerable › Vulnerabilities
CVE-2026-59293: SMB minimum protocol dialect defaults to SMB1
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-08-31
- Weakness: CWE-757
Description
Unless the application explicitly raises smbMinVersion, the jCIFS client will negotiate down to SMB1/CIFS, which lacks mandatory signing/encryption and is vulnerable to NTLM relay and content-tampering MITM. Spring Integration 7.1.0 Spring Integration 7.0.0 - 7.0.5 Spring Integration 6.5.0 - 6.5.10 Spring Integration 6.4.0 - 6.4.12
Affected products
- Spring Integration: from 6.4.0 before 6.4.13; from 6.5.0 before 6.5.11; from 7.0.0 before 7.0.5.1; from 7.1.0 before 7.1.0.1 — fixed in 6.4.13, 6.5.11, 7.0.5.1, 7.1.0.1
- Spring Integration: from 7.0.0 through 7.0.5; from 6.5.0 through 6.5.10; from 6.4.0 through 6.4.12; 7.1.0
How to fix
Upgrade to a fixed version: Spring Integration 6.4.13, 6.5.11, 7.0.5.1, 7.1.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-59293 or the next vulnerability affects your stack