What’s Vulnerable › Vulnerabilities
CVE-2026-59316: Spring Authorization Server Default Consent Page is vulnerable to Cross-Site Scripting (XSS)
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-27 · updated 2026-08-31
- Weakness: CWE-79
Description
Spring Authorization Server's default consent page renders user-controlled values without HTML entity encoding. When using the DefaultConsentPage, an attacker can craft an OAuth2 authorization request containing a malicious value that is stored server-side and later rendered unencoded in the default consent page presented to the end user. Spring Authorization Server 1.5.0 - 1.5.8 Spring Authorization Server 1.4.0 - 1.4.11
Affected products
- Spring Authorization Server: from 1.4.0 before 1.4.12; from 1.5.0 before 1.5.9 — fixed in 1.4.12, 1.5.9
How to fix
Upgrade to a fixed version: Spring Authorization Server 1.4.12, 1.5.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-59316 or the next vulnerability affects your stack