What’s Vulnerable › Vulnerabilities
CVE-2026-5937: Foxit PDF Editor/Reader's insufficient parameter validation leads to denial-of-service vulnerability
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-27 · updated 2026-10-26
- Weakness: CWE-248
Description
Insufficient parameter verification leads to the occurrence of format errors in files, which will trigger an unhandled "std::invalid_argument" exception, ultimately causing the program to terminate.
Affected products
- Foxit PDF Reader: before 13.2.4; from 14.0.0 before 14.0.4; from 2023.0.0 before 2026.1.1 — fixed in 13.2.4, 14.0.4, 2026.1.1
- Foxit Pdf Reader: before 2026.1.1 — fixed in 2026.1.1
How to fix
Upgrade to a fixed version: Foxit PDF Reader 13.2.4, 14.0.4, 2026.1.1; Foxit Pdf Reader 2026.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-5937 or the next vulnerability affects your stack