What’s Vulnerable › Vulnerabilities
CVE-2026-5941: Foxit PDF Editor/Reader AcroForm Signature Remote Code Execution Vulnerability
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-27 · updated 2026-10-26
- Weakness: CWE-20
Description
Parsing logic flaws cause non-signature data to be misidentified as valid signatures when processing malformed form field hierarchies, leading to invalid memory writes and program crashes during internal data structure construction.
Affected products
- Foxit PDF Reader: from 14.0.0 before 14.0.4; from 2023.0.0 before 2026.1.1 — fixed in 14.0.4, 2026.1.1
- Foxit Pdf Reader: before 2026.1.1 — fixed in 2026.1.1
How to fix
Upgrade to a fixed version: Foxit PDF Reader 14.0.4, 2026.1.1; Foxit Pdf Reader 2026.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-5941 or the next vulnerability affects your stack