What’s Vulnerable › Vulnerabilities

CVE-2026-5952: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.11 before 18.11.6, 19.0 before 19.0.3, and 19.1 before 19.1.1 that under certain conditions could have allowed an authenticated user with developer-role permissions to bypass package protection rules and overwrite protected Maven package metadata due to incorrect authorization checks.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.11.6, 19.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-5952 or the next vulnerability affects your stack