What’s Vulnerable › Vulnerabilities

CVE-2026-59657: Apache CloudStack: Sensitive Information Disclosure via Cleartext Storage in AsyncJob

Description

Cleartext Storage of Sensitive Information vulnerability in Apache CloudStack with AsyncJob storage in the database. This issue affects Apache CloudStack: from 4.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache CloudStack 4.20.3.1, 4.22.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-59657 or the next vulnerability affects your stack