What’s Vulnerable › Vulnerabilities
CVE-2026-59685: Apache HTTP Server: Out-of-Bounds Write in ap_directory_walk() Canonical-Name Rewrite on CASE_BLIND_FILESYSTEM
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-05
- Weakness: CWE-787
Description
Out-of-bounds Write vulnerability in Apache HTTP Server on Windows while processing paths with 8.3 names that may grow when expanded. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.
Affected products
- Apache HTTP Server: from 2.4.0 before 2.4.69 — fixed in 2.4.69
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.69. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2026/10/01/21
Get alerted when CVE-2026-59685 or the next vulnerability affects your stack