What’s Vulnerable › Vulnerabilities

CVE-2026-59799: Apache CloudStack: Missing Privilege Check in Two-Factor Authentication Disable Flow

Description

Improper Privilege Management vulnerability in Apache CloudStack's Two-factor authentication plugin allowing bypass of the two-factor authentication disable flow. This issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache CloudStack 4.20.3.1, 4.22.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-59799 or the next vulnerability affects your stack