What’s Vulnerable › Vulnerabilities
CVE-2026-59800: 9Router < 0.4.44 - OS Command Injection via sudoPassword Parameter in Tailscale Install Endpoint
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-07 · updated 2026-10-25
- Weakness: CWE-78
Description
9Router before 0.4.44 contains an OS command injection vulnerability in the unauthenticated POST /api/tunnel/tailscale-install endpoint (this route is not covered by the dashboard middleware matcher, so no authorization check is applied). The sudoPassword field from the request body is written to the stdin of a 'sudo -S sh' child process. When sudo does not prompt for a password (the process runs as root, NOPASSWD is configured, or a recent sudo timestamp cache exists), the sudoPassword value is interpreted by sh as a shell command, allowing a remote unauthenticated attacker to execute arbitrary OS commands. Exploitation evidence was first observed by the Shadowserver Foundation on 2026-07-04 (UTC).
Affected products
- decolua 9router: before 0.4.44 — fixed in 0.4.44
How to fix
Upgrade to a fixed version: decolua 9router 0.4.44. Check the vendor advisory for mitigations.
References
- https://github.com/decolua/9router/security/advisories/GHSA-g6g7-pvmx-m74p
- https://www.vulncheck.com/advisories/9router-os-command-injection-via-sudopassword-parameter-in-tailscale-install-endpoint
- https://github.com/decolua/9router/security/advisories/GHSA-g6g7-pvmx-m74p
Get alerted when CVE-2026-59800 or the next vulnerability affects your stack