What’s Vulnerable › Vulnerabilities
CVE-2026-59802: PasswordPusher < 2.8.1 - Redirect-Based XSS via data URI in URL Push Payload
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-10-24
- Weakness: CWE-183
Description
PasswordPusher before 2.8.1 accepts data URI schemes in URL push payloads due to insufficient validation in the valid_url function. Attackers can create malicious pushes containing data:text/html URIs that execute arbitrary JavaScript in victims' browsers when clicked, enabling phishing and credential theft under the trusted PasswordPusher domain.
Affected products
- PasswordPusher: before 2.8.1 — fixed in 2.8.1
How to fix
Upgrade to a fixed version: PasswordPusher 2.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/pglombardo/PasswordPusher/security/advisories/GHSA-76c2-66pg-fj2f
- https://www.vulncheck.com/advisories/passwordpusher-redirect-based-xss-via-data-uri-in-url-push-payload
- https://github.com/pglombardo/PasswordPusher/security/advisories/GHSA-76c2-66pg-fj2f
Get alerted when CVE-2026-59802 or the next vulnerability affects your stack