What’s Vulnerable › Vulnerabilities
CVE-2026-59820: LiteLLM: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-10-25
- Weakness: CWE-22
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.7-stable, LiteLLM Skills archive extraction did not sufficiently validate file paths from uploaded skill ZIP archives, allowing an authenticated user with access to LiteLLM LLM API routes or a key whose allowed_routes includes /v1/skills, anthropic_routes, or llm_api_routes to upload a crafted skill archive containing path traversal entries that could be written outside the intended extraction or staging directory. This issue is fixed in version 1.83.7-stable.
Affected products
- BerriAI litellm: before 1.83.7; 1.83.7-rc1 — fixed in 1.83.7
How to fix
Upgrade to a fixed version: BerriAI litellm 1.83.7. Check the vendor advisory for mitigations.
References
- https://github.com/BerriAI/litellm/commit/6a15adcd64137d37f73dee76dfe7481f8c2d9196
- https://github.com/BerriAI/litellm/pull/25475
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable
- https://github.com/BerriAI/litellm/security/advisories/GHSA-5jmr-gcrj-2c9q
Get alerted when CVE-2026-59820 or the next vulnerability affects your stack