What’s Vulnerable › Vulnerabilities
CVE-2026-59822: BerriAI LiteLLM Improper Authentication Vulnerability
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-09-02
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-10-25
- Weakness: CWE-287
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.84.0, LiteLLM's MCP Streamable HTTP endpoint allowed an unauthenticated attacker to use a fabricated Authorization header to trigger an OAuth2 passthrough fallback path that replaced failed LiteLLM key validation with an empty UserAPIKeyAuth() object, allowing requests to reach MCP tooling without a valid LiteLLM key. This issue is fixed in version 1.84.0.
Affected products
- BerriAI litellm: before 1.84.0 — fixed in 1.84.0
How to fix
Upgrade to a fixed version: BerriAI litellm 1.84.0. Check the vendor advisory for mitigations.
References
- https://github.com/BerriAI/litellm/commit/73869f0faf7d11ee21adcb5f91b8c33a340b6c2c
- https://github.com/BerriAI/litellm/pull/26463
- https://github.com/BerriAI/litellm/releases/tag/v1.84.0
- https://github.com/BerriAI/litellm/security/advisories/GHSA-7488-6r32-c95q
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-59822
- https://www.wiz.io/blog/ai-infrastructure-honeypot
Get alerted when CVE-2026-59822 or the next vulnerability affects your stack