What’s Vulnerable › Vulnerabilities
CVE-2026-59823: LiteLLM: Server-side request forgery via the `user_config` request parameter in LiteLLM Proxy
- Severity: medium (CVSS 5.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-30
- Weakness: CWE-918
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.9, an authenticated LiteLLM Proxy caller with a valid virtual key can place api_base inside the user_config request body to bypass is_request_body_safe, which blocks top-level api_base and base_url but previously did not inspect or reject user_config. Because user_config constructs the outbound router, the nested destination redirects a server-side request to an internal or external host selected by the caller and can expose endpoints the caller cannot otherwise access. This issue is fixed in version 1.83.9.
Affected products
- BerriAI litellm: before 1.83.9
References
- https://github.com/BerriAI/litellm/commit/47214be317f45a2d2ac08258362e0481411eb427
- https://github.com/BerriAI/litellm/pull/25827
- https://github.com/BerriAI/litellm/security/advisories/GHSA-hx8v-g79f-8w5f
Get alerted when CVE-2026-59823 or the next vulnerability affects your stack