What’s Vulnerable › Vulnerabilities
CVE-2026-59826: Metabase: Arbitrary Code Execution via Database Connection Detail Bypass
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-09 · updated 2026-07-30
- Weakness: CWE-94
Description
Metabase is an open-source business intelligence and embedded analytics tool. From 1.55.0 until 1.58.15.1, 1.59.12, 1.60.6.3, and 1.61.2, Metabase did not validate unsafe H2 connection properties on one database-creation code path, allowing an authenticated administrator to register a crafted H2 database connection and execute arbitrary Java code on the Metabase server. This issue is fixed in versions 1.58.15.1, 1.59.12, 1.60.6.3, and 1.61.2.
Affected products
- metabase: from 1.55.0 before 1.58.15.1; from 1.59.0 before 1.59.12; from 1.60.0 before 1.60.6.3; from 1.61.0 before 1.61.2 — fixed in 1.58.15.1, 1.59.12, 1.60.6.3, 1.61.2
How to fix
Upgrade to a fixed version: metabase 1.58.15.1, 1.59.12, 1.60.6.3, 1.61.2. Check the vendor advisory for mitigations.
References
- https://github.com/metabase/metabase/commit/74032e5e0a5a70dc45a6a744d37b9ba24eee8d01
- https://github.com/metabase/metabase/releases/tag/v0.58.15.1
- https://github.com/metabase/metabase/releases/tag/v0.59.12
- https://github.com/metabase/metabase/releases/tag/v0.60.6.3
- https://github.com/metabase/metabase/releases/tag/v0.61.2
- https://github.com/metabase/metabase/security/advisories/GHSA-8wx2-rxp2-4x35
Get alerted when CVE-2026-59826 or the next vulnerability affects your stack