What’s Vulnerable › Vulnerabilities
CVE-2026-59827: Metabase: Unsafe Deserialization of H2 Query Results
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-09 · updated 2026-07-13
- Weakness: CWE-502
Description
Metabase is an open-source business intelligence and embedded analytics tool. Prior to 1.58.15, 1.59.12, 1.60.6.3, and 1.61.1.4, Metabase instances with an H2 database connection, including the default sample database, deserialize arbitrary Java objects returned in H2 native query result columns of type OTHER without validation, allowing an authenticated user who can run native H2 queries to execute code on the Metabase server. This issue is fixed in versions 1.58.15, 1.59.12, 1.60.6.3, and 1.61.1.4.
Affected products
- metabase: from 0.58.0 before 0.58.15; from 0.59.0 before 0.59.12; from 0.60.0 before 0.60.6.3; from 0.61.0 before 0.61.1.4; from 1.58.0 before 1.58.15; from 1.59.0 before 1.59.12 — fixed in 0.58.15, 0.59.12, 0.60.6.3, 0.61.1.4, 1.58.15, 1.59.12
How to fix
Upgrade to a fixed version: metabase 0.58.15, 0.59.12, 0.60.6.3, 0.61.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/metabase/metabase/commit/00f42511fe3bc4385652a2e96862ee6fd7d42cf8
- https://github.com/metabase/metabase/releases/tag/v0.58.15
- https://github.com/metabase/metabase/releases/tag/v0.59.12
- https://github.com/metabase/metabase/releases/tag/v0.60.6.3
- https://github.com/metabase/metabase/releases/tag/v0.61.1.4
- https://github.com/metabase/metabase/security/advisories/GHSA-w95f-x9v9-wv36
Get alerted when CVE-2026-59827 or the next vulnerability affects your stack