What’s Vulnerable › Vulnerabilities
CVE-2026-59847: Libssh: libssh: integrity downgrade via openssl aes-gcm tag verification
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-21 · updated 2026-09-04
- Weakness: CWE-253
Description
A flaw was found in libssh. Incorrect AES-GCM finalization checks in builds using the OpenSSL backend can effectively remove integrity protection, allowing an in-path attacker to modify plaintext on the wire without detection.
Affected products
- libssh: from 0.9.0 before 0.11.5; 0.12.0 — fixed in 0.11.5
- Red Hat Enterprise Linux: 8.0, 9.0, 10.0
- RedHat Hardened Images: all versions
How to fix
Upgrade to a fixed version: libssh 0.11.5. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:42922
- https://access.redhat.com/errata/RHSA-2026:55855
- https://access.redhat.com/errata/RHSA-2026:62217
- https://access.redhat.com/errata/RHSA-2026:62218
- https://access.redhat.com/security/cve/CVE-2026-59847
- https://bugzilla.redhat.com/show_bug.cgi?id=2498180
Get alerted when CVE-2026-59847 or the next vulnerability affects your stack