What’s Vulnerable › Vulnerabilities
CVE-2026-59849: Libssh: libssh: denial of service via automatic certificate authentication loop
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-21 · updated 2026-09-22
- Weakness: CWE-835
Description
A flaw was found in libssh. Logic errors in automatic certificate-based public key authentication can cause libssh clients to loop indefinitely when configured certificates are missing or repeatedly rejected by a server, leading to denial of service.
Affected products
- libssh: from 0.11.0 before 0.11.5; 0.12.0 — fixed in 0.11.5
- Red Hat Enterprise Linux: 10.0, 10.2
- RedHat Enterprise Linux For Els: 10.2
- RedHat Enterprise Linux For Eus: 10.2
- RedHat Enterprise Linux For Ibm Z Systems: 10.0, 10.2
- RedHat Enterprise Linux For Ibm Z Systems Els: 10.2
- RedHat Enterprise Linux For Ibm Z Systems Eus: 10.2
- RedHat Enterprise Linux For Power Little Endian: 10.0, 10.2
- RedHat Enterprise Linux For Power Little Endian Els: 10.2
- RedHat Enterprise Linux For Power Little Endian Eus: 10.2
- RedHat Hardened Images: all versions
How to fix
Upgrade to a fixed version: libssh 0.11.5. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:42922
- https://access.redhat.com/errata/RHSA-2026:55855
- https://access.redhat.com/security/cve/CVE-2026-59849
- https://bugzilla.redhat.com/show_bug.cgi?id=2498182
Get alerted when CVE-2026-59849 or the next vulnerability affects your stack