What’s Vulnerable › Vulnerabilities
CVE-2026-59856: Vim: Arbitrary Code Execution via PHP Omni-Completion
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-09 · updated 2026-07-14
- Weakness: CWE-94
Description
Vim is an open source, command line text editor. Prior to 9.2.0736, the PHP omni-completion script in runtime/autoload/phpcomplete.vim interpolates a class or trait name, taken from the contents of the edited buffer, into a search() pattern that is run via win_execute() without escaping. A name containing a single quote can terminate the search() string argument early, and because the bar is honored as an Ex command separator, the remainder of the name is run as Ex commands; via the :! command this allows arbitrary operating-system command execution when a victim opens a crafted PHP file and invokes omni-completion. This issue is fixed in version 9.2.0736.
Affected products
- vim/vim: before 9.2.0736 — fixed in 9.2.0736
How to fix
Upgrade to a fixed version: vim/vim 9.2.0736. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/43afc581a37a35762dd0ef292f038b9dc5680a24
- https://github.com/vim/vim/security/advisories/GHSA-fh26-8f79-wj97
Get alerted when CVE-2026-59856 or the next vulnerability affects your stack