What’s Vulnerable › Vulnerabilities
CVE-2026-59865: Kiota: Command injection via x-ms-kiota-info dependencyInstallCommand surfaced by `kiota info`
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-16 · updated 2026-10-24
- Weakness: CWE-94
Description
Kiota is an OpenAPI based HTTP Client code generator. Prior to 1.29.1 and 1.32.5, `kiota info` read x-ms-kiota-info.languagesInformation.<language>.dependencyInstallCommand plus dependency name and version values from an OpenAPI description and presented the spec-supplied command as Kiota's recommended install command, allowing an attacker-controlled or compromised description to cause command injection when the suggested command was run manually or through the Kiota VS Code extension's kiota info --json dependency-install flow. This issue is fixed in version 1.29.1 and 1.32.5.
Affected products
- microsoft kiota: from 1.30.0, < 1.31.1; before 1.29.1
References
- https://github.com/microsoft/kiota/commit/e1d6d76c6eecbe50785429166faaf8c831e036c6
- https://github.com/microsoft/kiota/pull/7883
- https://github.com/microsoft/kiota/releases/tag/v1.32.5
- https://github.com/microsoft/kiota/security/advisories/GHSA-hq9q-27g5-qwpj
Get alerted when CVE-2026-59865 or the next vulnerability affects your stack