What’s Vulnerable › Vulnerabilities
CVE-2026-59878: Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All: AMQP NIO negative frame size validation bypass leading to DoS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-28 · updated 2026-08-05
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All. A remote unauthenticated peer that can reach an exposed AMQP NIO connector can trigger denial-of-service behavior by sending a frame size value. This cause the NIO threads to die and if done rapidly enough can lead to exhaustion of the NIO thread pool denying service to other connections. This issue affects Apache ActiveMQ AMQP: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8. Users are recommended to upgrade to version 5.19.9, 6.2.8, or 6.3.0 which fixes the issue.
Affected products
- Apache ActiveMQ: before 5.19.9; from 6.0.0 before 6.2.8 — fixed in 5.19.9, 6.2.8
- Apache Activemq All: before 5.19.9; from 6.0.0 before 6.2.8 — fixed in 5.19.9, 6.2.8
- Apache Activemq Amqp: before 5.19.9; from 6.0.0 before 6.2.8 — fixed in 5.19.9, 6.2.8
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.19.9, 6.2.8; Apache Activemq All 5.19.9, 6.2.8; Apache Activemq Amqp 5.19.9, 6.2.8. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/dnyx4d2oldshcj4lthso7b53y4bqmjvn
- http://www.openwall.com/lists/oss-security/2026/07/27/7
Get alerted when CVE-2026-59878 or the next vulnerability affects your stack