What’s Vulnerable › Vulnerabilities
CVE-2026-59884: pyasn1 BER/CER/DER decoder denial of service via unbounded long-form tag IDs
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-07-21
- Weakness: CWE-400
Description
pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.4, the BER decoder shared by the CER and DER codecs parses long-form tags by accumulating continuation octets without an upper bound on the tag ID size, allowing a crafted input to force construction of an arbitrarily large integer with CPU cost growing quadratically and to trigger unhandled ValueError exceptions in Python 3.11+ error formatting paths. Any application decoding untrusted BER, CER, or DER input is affected. This issue is fixed in version 0.6.4.
Affected products
- pyasn1: before 0.6.4 — fixed in 0.6.4
How to fix
Upgrade to a fixed version: pyasn1 0.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/pyasn1/pyasn1/commit/628e36ecbb5277a3f01572ce418ef54271b165a5
- https://github.com/pyasn1/pyasn1/releases/tag/v0.6.4
- https://github.com/pyasn1/pyasn1/security/advisories/GHSA-m4p7-r5rc-7g4j
Get alerted when CVE-2026-59884 or the next vulnerability affects your stack