What’s Vulnerable › Vulnerabilities
CVE-2026-59898: Netty: WebSockets V07/V08 handshaker missing Connection/Upgrade validation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-29 · updated 2026-08-06
- Weakness: CWE-444
Description
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.
Affected products
- netty: before 4.1.136; from 4.2.0 before 4.2.16 — fixed in 4.1.136, 4.2.16
How to fix
Upgrade to a fixed version: netty 4.1.136, 4.2.16. Check the vendor advisory for mitigations.
References
- https://github.com/netty/netty/releases/tag/netty-4.1.136.Final
- https://github.com/netty/netty/releases/tag/netty-4.2.16.Final
- https://github.com/netty/netty/security/advisories/GHSA-4mp9-239f-g9hg
Get alerted when CVE-2026-59898 or the next vulnerability affects your stack