What’s Vulnerable › Vulnerabilities
CVE-2026-59927: Mistune directives/include: mutual `.. include::` recursion crashes the renderer with `RecursionError`, denial of service via two attacker-controlled markdown files
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-08 · updated 2026-10-25
- Weakness: CWE-674
Description
Mistune is a Python Markdown parser with renderers and plugins. Prior to 3.3.0, the Include directive in src/mistune/directives/include.py detects only direct self-includes and not indirect cycles, allowing two markdown files that include each other to trigger unbounded recursion, raise RecursionError, and crash the rendering request. This issue is fixed in version 3.3.0.
Affected products
- lepture mistune: before 3.3.0 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: lepture mistune 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/lepture/mistune/commit/1bef343ade163fc3bb95572b15be720084cdb993
- https://github.com/lepture/mistune/releases/tag/v3.3.0
- https://github.com/lepture/mistune/security/advisories/GHSA-8mpj-m6qm-5qr8
Get alerted when CVE-2026-59927 or the next vulnerability affects your stack