What’s Vulnerable › Vulnerabilities
CVE-2026-59947: Composer: URL-embedded HTTP-Basic username leaks to verbose logs (GitHub PAT exposure)
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-07-10
- Weakness: CWE-532
Description
Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, when Composer is run with -vvv debug verbosity, it could print a credential embedded in the username slot of a repository or package URL, such as a GitHub Personal Access Token in https://TOKEN@host/, to debug output because AuthHelper, Url::sanitize, and ProcessExecutor did not sanitize username-only URL credentials. This issue is fixed in versions 2.2.29 and 2.10.2.
Affected products
- Packagist Composer/Composer: from 2.3.0 before 2.10.2; from 1.0.0 before 2.2.29; 2.10.0, 2.10.0-RC1, 2.10.0-RC2, 2.10.1, 2.3.0, 2.3.1 (+213) — fixed in 2.10.2, 2.2.29
- composer: from 1.0, < 2.2.29; from 2.3.0, < 2.10.2
How to fix
Upgrade to a fixed version: Packagist Composer/Composer 2.10.2, 2.2.29. Check the vendor advisory for mitigations.
References
- https://github.com/composer/composer/commit/6bd66874ae523ecb69aca5964487a0cdfda03ef8
- https://github.com/composer/composer/commit/8887ad76fbd830cb1861a2b1fd8ead78ed1fa1ec
- https://github.com/composer/composer/releases/tag/2.10.2
- https://github.com/composer/composer/releases/tag/2.2.29
- https://github.com/composer/composer/security/advisories/GHSA-g6xq-892h-64w3
Get alerted when CVE-2026-59947 or the next vulnerability affects your stack