What’s Vulnerable › Vulnerabilities
CVE-2026-60005: NGINX ngx_http_slice_module vulnerability
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-08-11
- Weakness: CWE-908
Description
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_slice_module module. When the slice directive and unnamed regex captures are configured or when a background cache update happens, unauthenticated attackers can send requests that may cause uninitialized memory access in the NGINX worker process, leading to limited disclosure of memory or a restart. Impact: This vulnerability may allow remote, unauthenticated attackers to have limited control to disclose memory contents or restart the NGINX worker process. There is no control plane exposure; this is a data plane issue only. Note: The ngx_http_slice_module module is not enabled by default; it's enabled with the --with-http_slice_module configuration parameter. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Gateway Fabric: from 1.3.0 through 1.6.2; from 2.0.0 before 2.6.7 — fixed in 2.6.7
- F5 NGINX Ingress Controller: from 3.5.0 through 3.7.2; from 5.0.0 before 5.5.3; from 2026-lts-r1 before 2026-lts-r4; 4.0.0, 4.0.1 — fixed in 2026-lts-r4, 5.5.3
- F5 NGINX Instance Manager: from 2.17.0 before 2.22.2 — fixed in 2.22.2
- F5 NGINX Open Source: from 1.30.0 before 1.30.4; 1.31.2 — fixed in 1.30.4
- F5 NGINX Plus: from 37.0.0.1 before 37.0.3.1; from r33 before r36; r36, r36-p1, r36-p2, r36-p3, r36-p4, r36-p5 (+1) — fixed in 37.0.3.1, r36
- F5 Waf: from 4.11.0 through 4.16.0; from 5.2.0 through 5.8.0; from 5.9.0 before 5.13.4 — fixed in 5.13.4
How to fix
Upgrade to a fixed version: F5 NGINX Gateway Fabric 2.6.7; F5 NGINX Ingress Controller 2026-lts-r4, 5.5.3; F5 NGINX Instance Manager 2.22.2; F5 NGINX Open Source 1.30.4; F5 NGINX Plus 37.0.3.1, r36; F5 Waf 5.13.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-60005 or the next vulnerability affects your stack