What’s Vulnerable › Vulnerabilities
CVE-2026-60062: NGINX Agent Vulnerability
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-08-06
- Weakness: CWE-22
Description
The NGINX Agent config_dirs directive allows a low-privileged attacker to gain limited read and write access to files outside of the designated secure directory. The config_dirs directive required for this issue can also be configured through NGINX Instance Manager. A successful exploit may allow an attacker to cross a security boundary. Impact: A remotely authenticated low-privileged attacker could gain limited read and write access outside of the list of directories specified in the NGINX Agent configuration. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Agent: from 2.37.0 before 2.46.7 — fixed in 2.46.7
- F5 NGINX Instance Manager: from 2.17.1 before 2.22.2 — fixed in 2.22.2
How to fix
Upgrade to a fixed version: F5 NGINX Agent 2.46.7; F5 NGINX Instance Manager 2.22.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-60062 or the next vulnerability affects your stack