What’s Vulnerable › Vulnerabilities
CVE-2026-60080: Apache Fory: Rust MetaString heap use-after-free
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-21 · updated 2026-10-24
- Weakness: CWE-416
Description
Use After Free vulnerability in the Rust deserialization logic of Apache Fory. This issue affects Apache Fory from 0.13.0 through 1.3.0. A crafted Fory payload could cause undefined behavior, process crash, or potential memory disclosure. Users are recommended to upgrade to version 1.4.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Fory: from 0.13.0 before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Fory 1.4.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/svnq03f3ls7vsgk8md4hjmmw1z6stbvy
- http://www.openwall.com/lists/oss-security/2026/07/21/3
Get alerted when CVE-2026-60080 or the next vulnerability affects your stack