What’s Vulnerable › Vulnerabilities
CVE-2026-60082: DBI versions before 1.651 for Perl do not enforce statement handle consistency with the row
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-10-24
- Weakness: CWE-125
Description
DBI versions before 1.651 for Perl do not enforce statement handle consistency with the row. When the statement handle had no fields but the source row was non-empty, the internal row-buffer helper would read from a negative array index. This could be triggered by a caller supplying inconsistent metadata and rows to the prepare method.
Affected products
- HMBRAND DBI: before 1.651 — fixed in 1.651
How to fix
Upgrade to a fixed version: HMBRAND DBI 1.651. Check the vendor advisory for mitigations.
References
- https://github.com/perl5-dbi/dbi/commit/397868704291bbf0989b97e2c0661189890653e2.patch
- https://github.com/perl5-dbi/dbi/security/advisories/GHSA-rwhc-hhmv-cjvg
- https://metacpan.org/release/HMBRAND/DBI-1.651/changes
- http://www.openwall.com/lists/oss-security/2026/07/14/13
Get alerted when CVE-2026-60082 or the next vulnerability affects your stack