What’s Vulnerable › Vulnerabilities
CVE-2026-60085: PraisonAI before 4.6.78 Unenforced Security Policy in Subprocess Sandbox
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-10-24
- Weakness: CWE-273
Description
PraisonAI before 4.6.78 contains an unenforced security policy vulnerability in the default Subprocess Sandbox backend where blocked_commands, blocked_paths, blocked_imports, allow_subprocess, and allow_file_write restrictions are completely ignored. Attackers can execute arbitrary subprocess commands, read sensitive files, and perform destructive operations despite explicit security policy configuration.
Affected products
- MervinPraison PraisonAI: before 4.6.78 — fixed in 4.6.78
How to fix
Upgrade to a fixed version: MervinPraison PraisonAI 4.6.78. Check the vendor advisory for mitigations.
References
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-5r6c-gj4g-r697
- https://www.vulncheck.com/advisories/praisonai-before-unenforced-security-policy-in-subprocess-sandbox
Get alerted when CVE-2026-60085 or the next vulnerability affects your stack