What’s Vulnerable › Vulnerabilities
CVE-2026-60119: Hi.Events < 1.11.0 XSS via Event Title JSON.stringify Injection
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-10-24
- Weakness: CWE-862
Description
Hi.Events before 1.11.0 contains a cross-site scripting vulnerability that allows authenticated attackers with event creation or edit permissions to inject arbitrary HTML and JavaScript by embedding a malicious event title containing the </script> sequence, which is not escaped by JSON.stringify() when embedded in inline script tags. Attackers can craft an event title that breaks out of the script context in the application/ld+json structured data block or server-side rehydrated state, causing the payload to execute in the browser of any user who views the public event page, including unauthenticated visitors and authenticated administrators.
Affected products
- HiEventsDev Hi.Events: before 1.11.0 — fixed in 1.11.0
How to fix
Upgrade to a fixed version: HiEventsDev Hi.Events 1.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/HiEventsDev/Hi.Events/commit/1e36b070771801ed7113255ef7b3a7f271a2a794
- https://github.com/HiEventsDev/Hi.Events/pull/1260
- https://github.com/HiEventsDev/Hi.Events/releases/tag/v.1.11.0-beta
- https://github.com/HiEventsDev/Hi.Events/security/advisories/GHSA-2ggx-79g6-2jmj
- https://www.vulncheck.com/advisories/hi-events-beta-xss-via-event-title-json-stringify-injection
- https://github.com/HiEventsDev/Hi.Events/security/advisories/GHSA-2ggx-79g6-2jmj
Get alerted when CVE-2026-60119 or the next vulnerability affects your stack