What’s Vulnerable › Vulnerabilities
CVE-2026-60120: Bagisto < 2.4.4 Stored XSS via CSTI in create.blade.php
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-09 · updated 2026-10-25
- Weakness: CWE-79
Description
Bagisto before 2.4.4 contains a stored cross-site scripting vulnerability via client-side template injection that allows unauthenticated attackers to execute arbitrary JavaScript in administrator browsers by registering a customer account with malicious payload in the first or last name field. The create.blade.php template renders customer name fields without the Vue.js v-pre directive, causing Vue.js to evaluate stored template expressions as live JavaScript when an administrator opens the Create Order page for the affected customer.
Affected products
- Webkul Bagisto: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: Webkul Bagisto 2.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/bagisto/bagisto/commit/49d0c3fc90dedf8782c45c5979df4f4595d6bb97
- https://github.com/bagisto/bagisto/releases/tag/v2.4.4
- https://www.vulncheck.com/advisories/bagisto-stored-xss-via-csti-in-create-blade-php
Get alerted when CVE-2026-60120 or the next vulnerability affects your stack