What’s Vulnerable › Vulnerabilities
CVE-2026-6092: Encrypt-then-MAC could fall back to MAC-then-Encrypt when HAVE_ENCRYPT_THEN_MAC is configured
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-06-27
- Weakness: CWE-757
Description
When HAVE_ENCRYPT_THEN_MAC is configured, the implementation could fall back to MAC-then-Encrypt rather than enforcing Encrypt-then-MAC.
Affected products
- wolfSSL: from 5.2.0 before 5.9.2 — fixed in 5.9.2
How to fix
Upgrade to a fixed version: wolfSSL 5.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6092 or the next vulnerability affects your stack