What’s Vulnerable › Vulnerabilities
CVE-2026-6094: Heap buffer overread in wc_PKCS7_DecodeEnvelopedData parsing crafted PKCS7 EnvelopedData
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-06-26
- Weakness: CWE-125
Description
Heap buffer overread in wc_PKCS7_DecodeEnvelopedData when parsing crafted PKCS7 EnvelopedData. This could theoretically be triggered by attacker-supplied data delivered via S/MIME or CMS.
Affected products
- wolfSSL: from 5.8.0 before 5.9.2 — fixed in 5.9.2
How to fix
Upgrade to a fixed version: wolfSSL 5.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6094 or the next vulnerability affects your stack